Resolved
Added details about root cause being a missing database index.
Resolved
Updated incident timeline
Resolved
Incident resolved, service confirmed to be operating normally. We appreciate your patience and understanding with our team today as we worked to address this
Identified
We are investigating an issue regarding degraded performance on the Stagehand API due to a missing database index. Our team has identified the issue and is actively rolling out the new index which should correct the performance issue promptly.